Наверх

Если iPhone или iPad не обновляется. Ошибка «this device isn’t eligible for the requested build»

Сегодня, в воскресенье, должен выйти джейлбрейк для iOS 6.1. Если вы решили сохранить SHSH при помощи утилиты Tinyumbrella, но при этом не учли, что сначала нужно обновить свой iPhone, iPad или iPod Touch до версии iOS 6.1, то при обновлении своего устройства через iTunes Вы получите ошибку в которой написана фраза «this device isn’t eligible for the requested build«.

Решаем ошибку «this device isn’t eligible for the requested build» в Mac OS

Чтобы избавиться от этой ошибки, необходимо поставить знак # в файле Hosts перед строчками, которые содержат gs.apple.com, но перед тем как это сделать, рекомендую сохранить копию этого файлы на всякий случай. Сам файл располагается в папке /private/etc/hosts 

Сохранили? Тогда запускаем терминал и пишем следующее:

sudo nano /etc/hosts

Нажимаем Enter и вводим свой пароль. Не бойтесь, если пароль не отображается. Это сделано специально, чтобы никто не смог увидеть его на экране.

Появится окно с возможностью редактирования файла hosts. В нем надо добавить знак «#» (без кавычек), перед строчками, которые содержат слова gs.apple.com.

this device isn't eligible for the requested build

После этого необходимо сохранить изменения. Для этого воспользуйтесь сочетанием клавиш Ctrl+O (Буква), Enter (подтверждаем перезапись), а затем CMD+X (для выхода).

Откройте терминал заново и введите строчку:

dscacheutil -flushcache

и нажмите Enter, а после — CMD+Q. Этой командой мы обновили записи. После этого подключите свой iPhone, iPad или iPod Touch к iTunes и обновите устройство. Ошибки больше не будет.

Ваши комментарии

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

This blog is kept spam free by WP-SpamFree.